В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AlinaLay
AlinaLay
28.04.2022 22:07 •  Информатика

Напишите на Напишите программу, которая находит в массиве номера элементов, равных минимальному. Входные данные

Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные

Программа должна вывести в одной строке номера элементов массива, равных минимальному, разделив их пробелами.

Ответ:
КРИЛЛ2000
КРИЛЛ2000
01.02.2021 16:40

#include <iostream>

using namespace std;

int main() {

int N, min;

cin >> N;

int* array = new int[N];

for (int i = 0; i < N; i++)

 cin >> array[i];

min = array[0];

for (int i = 1; i < N; i++) {

 if (array[i] < min)

  min = array[i];

}

for (int i = 0; i < N; i++) {

 if (array[i] == min)

  cout << i << " ";

}

delete[] array;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?