В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Маис555
Маис555
22.03.2021 09:23 •  Информатика

Составить программу, используя одномерные массивы: Найти наименьший элемент в числовом массиве М (20), который лежит в интервале [10.50]​
(Pascal)

Ответ:

var

 m: array[1..20] of integer;

 i, min: integer;

begin

 randomize;

 min := 100;

 WriteLn('Массив:');

 for i := 1 to 20 do

 begin

   m[i] := random(100);

   Write(m[i], ', ');

   if (m[i] < min) and (m[i] >= 10) and (m[i] <= 50) then min := m[i];

 end;

 WriteLn;

 if min <> 100 then WriteLn('Минимальный элемент массива в интервале [10..50] равен ', min)

    else WriteLn('Массив не содержит элементов в интервале [10..50]');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?