В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Попова1234
Попова1234
05.05.2020 16:50 •  Информатика

Впаскале составить программу: определить делимость на 3 для четырехзначного числа. (думаю, что надо использовать св-во делимости числа: число будет делиться на 3, если сумма цифр этого числа будет делиться на три)

Ответ:
sonya20067
sonya20067
13.06.2020 13:35

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;  //Цифры четырехзначного числа

 

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a1:= a div 1000;

  a2:= (a mod 1000) div 100;

  a3:= (a mod 100) div 10;

  a4:= a mod 10;

  if (a1 + a2 + a3 + a4) mod 3 = 0 then writeln(a, ' делится на 3')

  else writeln(a, ' не делится на 3');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?