В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
даниил853
даниил853
12.03.2022 06:04 •  Информатика

Составить программу нахождения наибольшего общего делителя нескольких чисел, используя функцию нахождения НОД двух чисел.

Ответ:
sofikolomiets04
sofikolomiets04
25.02.2021 23:17

program HomeWork;

var a,b,c: integer;

begin

 write('Введите два целых числа через пробел: '); readln(a, b);

 c := a mod b;

 while c <> 0 do

 begin

   a := b;

   b := c;

   c := a mod b;

 end;

 write(b)

end.

0,0(0 оценок)
Ответ:
Smazi
Smazi
25.02.2021 23:17

Паскаль. Вычисляет НОД для любого кол-ва чисел

Объяснение:

function Nod(a,b:integer):integer;{определение НОД двух чисел}

begin

while a<>b do

if a>b then a:=a-b else b:=b-a;

Nod:=a;

end;

var

   a: array of integer;

   n, i: integer;

   k: integer;

begin

 WriteLn('*** Определение НОД нескольких чисел ***');

 Write('Введите кол-во чисел N = '); ReadLn(n);

 SetLength(a, n + 1);

 WriteLn('Введите числа: ');

 for i := 1 to n do

  begin

   Write(i,'-e число: '); ReadLn(a[i]);

  end;

 WriteLn;

 k := Nod(a[1], a[2]);

 for i := 3 to n do k := nod(k, a[i]);

 WriteLn('Общий НОД всех чисел = ', k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?