В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу на языке Pascal. Занесите информацию о десяти европейских странах в массивы. Найдите максимальную численность населения Вот страны:Россия, США, Греция, КНР, Турция, Германия, Испания, Колумбия, Бразилия, Египет

Ответ:
AlexisA031117
AlexisA031117
16.02.2021 21:14

Плотность, я так понимаю, населения на квадратный километр? Взял инфу из Wiki. Вот что получилось:

program HomeWork;

const countries:array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');

const density:array[1..10] of real = (8.56,32,81,650,100,230,92,39,23.6,80);

var i:integer;

var d:real;

var s:string;

begin

   d := 0;

   for i := 1 to length(density) do

       begin

           if d < density[i] then

               begin

                   d := density[i];

                   s := countries[i];

               end;

       end;

   writeln('Самая большая плотность в ', s, ', и она равна ', d:3:0, ' человек на квадратный километр')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?