В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
treetmeh
treetmeh
26.06.2022 10:18 •  Информатика

написать программу на языке С#. Дан массив размером nxm, элементы которого целые числа. Подсчитать среднее арифметическое четных элементов, расположенных ниже главной диагонали.

Ответ:
AnnaLOVEannaLOVEanna
AnnaLOVEannaLOVEanna
02.12.2020 17:59

на локальных тестах работает

Объяснение:

using System;

class Program

{

   static int P(string p)

   {

       int a = 0, dec = 1;

       for (int i = p.Length - 1; i >= 0; i--)

       {

           a += (p[i] - '0') * dec;

           dec *= 10;

       }

       return a;

   }

   static void Main(string[] args)

   {

       int n = int.Parse(Console.ReadLine());

       int m = int.Parse(Console.ReadLine());

       int c = 0, sum = 0;

       for (int i = 0; i < n; i++)

       {

           int nowSum = 0;

           string a = Console.ReadLine();

           string[] now = a.Split(' ');

           for (int j = 0; j < i; j++)

           {

               int num = P(now[j]);

               if (num % 2 == 0)

               {

                   c++;

                   sum += num;

               }

           }

       }

       Console.WriteLine(sum / c);

       Console.ReadLine();

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?