В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
05NARIMAN05
05NARIMAN05
12.01.2022 23:20 •  Информатика

Дан массив из 100 целых чисел. Написать программу нахождения суммы нечетных элементов массива. C++

Ответ:
antonkovalenko1
antonkovalenko1
28.12.2020 15:56

#include <iostream>

#include <time.h>

using namespace std;

int main()

{

srand(time(NULL));

int N[100];

int sum = 0;

for(int i=0;i<100;i++){

 N[i] =rand();

}

cout << "vse elementu" << endl;

for(int i=0;i<100;i++)

 cout << N[i] << " ";

cout << endl;

cout << "nechetnue elementu" << endl;

for(int i=0;i<100;i++){

 if(N[i]%2!=0)

  sum = sum + N[i];

  cout << N[i] << " ";

}

cout << endl;

cout<< "suma nechetnuh =  " << sum << endl;

system("pause");

return 0;

}

Объяснение:

Написал программу так, что-бы сначала выводило 100 элементов(рандом чисел), потом выводило нечетные элементы, потом выведет уже суму нечетных

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?