В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
matematic14
matematic14
08.05.2021 13:08 •  Информатика

Написать программу на языке Си. Дано целое число N и последовательность, состоящая из N целых чисел. Вывести
сумму чисел из данной последовательности, которые больше своего левого соседа.

Ответ:
Cvetochek554
Cvetochek554
01.12.2020 11:23

#include <stdio.h>

int main() {

 

int n;

scanf("%d", &n);

 

 

int a, b, tmp, ans = 0;

scanf("%d", &tmp);

for (int i = 1; i < n; i++)

{

 int a;

 scanf("%d", &a);

 if (a > tmp)ans += a;

 tmp = a;

}

printf("%d", ans);

getchar();

getchar();

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?