В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dimadenisen
dimadenisen
24.05.2022 07:48 •  Информатика

РЕШИТЕ ЗАДАЧУ НА ПРОСТОЙ КОД - БЕЗ МАССИВОВ. ЗАРАНЕЕ ОГРОМНОЕ Определите сумму всех элементов последовательности, завершающейся числом 0. Формат входных данных Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания. Формат выходных данных Выведите ответ на задачу. Sample Input: 3 6 8 0 Sample Output: 17

Ответ:
Hdhfr
Hdhfr
15.10.2020 15:56

import java.util.Scanner;

class Main {

   static int getNumb() {

       Scanner numb = new Scanner(System.in);

       return numb.nextInt();

   }

   public static void main(String [ ] args) {

       int sum = 0;

       int x;

       while(true) {

           x = getNumb();

           if(x != 0) {

               sum += x;

           }

           else {

               break;

           }

       }

       System.out.print(sum);

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?