В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KateHe
KateHe
16.04.2021 22:20 •  Информатика

Язык Python3 Простое число
По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число.

Входные данные

Во входном файле находится одно натуральное число K.

Выходные данные

В выходной файл выведите K-е простое число.

Примеры

Ввод:
3
Вывод:
5
Ввод:
1
Вывод:
2

Ответ:
Юлия0981
Юлия0981
15.10.2020 14:00

Ну, можно так:

Объяснение:

def prostoe(chislo):

   a = True

   for i in range(2, chislo//2 + 1):

       if chislo % i == 0:

           a = False

           break

   return a

k = int(input("Введите число, не превосходящие 100000: "))

schetchic = 1

a = 2

while k >= schetchic:

   if prostoe(a):

       prostoi = a

       schetchic += 1

   a += 1

print(prostoi)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?