В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
иван1208
иван1208
10.10.2021 18:24 •  Информатика

Напишите программу в С++, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.Программа должна быть рабочей

Ответ:
Kate27love
Kate27love
15.10.2020 13:20

#include <iostream>

#include <vector>

#include <ctime>

using namespace std;

int main() {

setlocale (LC_ALL, "Russian");

int counter = 0;

vector<int> numbers;

int buffer = 0;

do {

   cin >> buffer;

     numbers.push_back(buffer);

 } while (buffer != 0||numbers.size()==1000);

 numbers.pop_back();

 for(int i = 0; i<numbers.size(); ++i) {

  if(numbers[i]%3==0&&numbers[i]%2!=0) {

  ++counter;

}

}

cout << endl << "Колво нечётных чисел, кратных 3: " << counter;  

cout << endl << "Всего чисел: " << numbers.size();  

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?