В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Решить в dev c++ и желательно блок-схему Дан одномерный массив, состоящий из 10 элементов. Пользователь вводит элементы массива. Вывести на экран исходный массив и в строку только четные элементы массива.
Входные данные -9 6 2 7 3 -4 -6 0 2 4
Выходные данные -9 6 2 7 3 -4 -6 0 2 4 6 2 -4 -6 2 4

Ответ:
Gutrom
Gutrom
13.08.2020 11:49

#include <iostream>

#include <ctime>

using namespace std;

int main() {

setlocale (LC_ALL, "Russian");

cout << "Кол-во элементов массива: ";

int N; cin >> N; int a[N];

for(int i = 0; i < N; ++i) {

 cout << "Элемент #" << i << ": ";

 cin >> a[i];

}

 cout << "Массив: ";

for(int i = 0; i < N; ++i) {

 cout << a[i] << " ";

}

 cout << endl << "Чётные элементы: ";

 for(int i = 0; i < N; ++i) {

 if(a[i]%2==0) {

 cout << a[i] << " ";

 }

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?