В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Boss2243
Boss2243
28.06.2021 13:18 •  Информатика

На языке программирования С++ составить программу, которая по введенному номеру дня недели выводит его название.

Ответ:
Romaniopatronys
Romaniopatronys
04.06.2020 19:06

/*

   Методов решения много, самый но длинный - это switch ... case..

   Можно было использовать map из STL

*/

#include <iostream>

#include <vector>

#include <sstream>

using namespace std;

int main()

{

   int number;

   cin>>number;

   switch (number){

   case 1:

       cout<<"Понедельник\n";

       break;

   case 2:

       cout<<"Вторник\n";

       break;

   case 3:

       cout<<"Среда\n";

       break;

   case 4:

       cout<<"Четверг\n";

       break;

   case 5:

       cout<<"Пятница\n";

       break;

   case 6:

       cout<<"Суббота\n";

       break;

   case 7:

       cout<<"Воскресенье\n";

       break;

   default:

       cout<<"Нет дня недели под этим номером";

   }

   return 0;

}

Краткий гайд:

number - переменная, отвечает за номер дня неделиswitch - case - оператор множественного выбора. Подробнее читаем на cppstudio.com, cppreference.com или других порталах
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?