В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vlad2005Mr
Vlad2005Mr
01.10.2022 11:15 •  Информатика

Составьте программу на языке Паскаль для вычисления суммы:
Р = 4 + 7 +10 + 13. . . + K , где P>4

Ответ:
Мelissa205
Мelissa205
15.10.2020 10:47

[any] Pascal:

var K, P, i: integer; begin  Read(K);  i := 1;  while i < K do  begin    i := i + 3;    P := P + i;  end;  Write(P); end.

PascalABC.NET:

Используя формулу для нахождения суммы первых n членов арифметической прогрессии:  S_n = \frac{a_1 + a_n}{2} * (\frac{a_n - a_1}{a_2 - a_1} + 1), где a_1 — первый член прогрессии, a_2 — второй член прогрессии, a_n — член под номером n (в нашем случае a_n — это K)

##var K := ReadInteger('K:');Print('S:', (4+K)/2*((K-4)/(7-4)+1))

 

Пример работы:


Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P>4
Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P>4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?