В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
юлия1657
юлия1657
29.09.2021 01:24 •  Информатика

Составьте программу, которая по введенному вами K - числу грибов печатает фразу <Мы нашли в лесу K грибов>, причем согласовывает окончание слова <гриб> с числом K. Количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. Окончание фразы определяется значением последней цифры.

Ответ:
Плаоцтвтч
Плаоцтвтч
19.05.2020 12:30

if k<0 then

   writeln('Не может такого быть')

 else

   begin

     write('Мы нашли в лесу ',k,' гриб');

     if (k mod 100 in [5..19]) then

       writeln('ов')

     else if (k mod 10 in [2..4]) then

       writeln('а')

     else if (k mod 10=1) then

       writeln

     else

       writeln('ов');

   end;

   end.

0,0(0 оценок)
Ответ:

k = int(input ('Сколько вы нашли грибов? : '))

if k == 1 :

print('Я нашел 1 гриб')

if k == 2 :

print('Я нашел 2 гриба')

if k == 3 :

print('Я нашел 3 гриба')

if k == 4 :

print('Я нашел 4 гриба')

if k >= 5 :

print ('Я нашел ' + str(k) + ' грибов!')

Если вы хотите отблагодарить меня, то поставьте этому ответу "Лучший".

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?