В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
molkes
molkes
28.03.2023 12:20 •  Информатика

Составить программу в паскаль. с клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. определить: 1.максимальное число в этой последовательности. 2.количество четных чисел.

Ответ:
ĪīDanilaīī
ĪīDanilaīī
31.07.2020 14:23
//Pascal ABC.NET v3.0 сборка 1111
var
 a,k,max:integer;
begin
a:=1;
max:=-1000;
k:=0;
 while a<>0 do
  begin;
   if not(odd(a)) then inc(k);
   if max<a then max:=a;
   readln(a);
  end;
writeln('Max=',max,', not odd:',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?