В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mirakle1
mirakle1
01.09.2021 01:07 •  Информатика

Дан массив S из 20 вещественных чисел. Составить программу, с которой можно ввести элементы массива и определить есть ли элементы массива равные элементу S[15], и вывести их сумму.

Ответ:
SANMAN26
SANMAN26
15.10.2020 00:14

var s:array[1..20] of real;

i:integer;

sum_mas: real;

begin

sum_mas:= 0;

for i:=1 to 20 do readln(s[i]);

for i:=1 to 20 do

if (s[15] = s[i]) then sum_mas:= sum_mas + s[i];

write(sum_mas);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?