В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hdjdjdjsdusjhdjd
hdjdjdjsdusjhdjd
25.08.2021 10:07 •  Информатика

Составить программу. дано натуральное число n. подсчитать количество цифр этого числа.

Ответ:
aidos0278gmailcom
aidos0278gmailcom
19.07.2020 13:23
Var
  n: longint;
  s: string;
  k: byte;

begin
  Write('Введите натуральное число '); Readln(n);
  { Преобразуем число к строке, убрав знак (мало ли...) }
  Str(abs(n), s);
  { Выведем длину полученной строки }
  Writeln('Количество цифр в числе равно ', Length(s))
end.

Тестовое решение:
Введите натуральное число 164275353
Количество цифр в числе равно 9
0,0(0 оценок)
Ответ:
Qqertyi
Qqertyi
19.07.2020 13:23
Program chisla;
uses crt;
var a,b,c: integer;
begin
writeln('Введите натуральное число: ');
readln(a);
b:=a;
c:=0;
while b <>0 do
begin
c:=c+1;
b:= b div 10;
end;
writeln('B числе ',a,' - ',c, ' цифр');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?