В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nigar26
nigar26
23.01.2022 14:23 •  Информатика

Напишите программу с массивами
Дан одномерный массив, состоящий из 10 элементов. Пользователь вводит элементы массива. Вывести массив на экран в строку (перед выводом результата экран очистить). Сосчитать и вывести на экран сумму нечетных элементов массива.

Входные данные
-9 6 2 7 3 -4 -6 0 2 4
Выходные данные
-9 6 2 7 3 -4 -6 0 2 4 1

Ответ:
эма24
эма24
14.10.2020 21:36

var a:array[1..10] of integer;

sumer, i:integer;

Begin

for i:=1 to 10 do readln(a[i]);

for i:=1 to 10 do begin

write(a[i], ' ');

if (a[i] mod 2 = 1) then sumer:= sumer + a[i];

end;

write(' ', sumer);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?