В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Anastasii777
Anastasii777
10.08.2022 22:11 •  Информатика

Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.

Ответ:
алькамалька
алькамалька
14.10.2020 20:37

#include <iostream>

using namespace std;

signed main() {

   freopen("input.txt","r",stdin);

   freopen("output.txt","w",stdout);

   int x;

   double sum = 0,dif = 0;

   while(cin >> x){

       if(x % 2 == 0)

           sum += x;

       else

           dif -= x;

   }

   cout << sum/dif;

   fclose (stdout);

}

0,0(0 оценок)
Ответ:
миларыбка
миларыбка
14.10.2020 20:37

// PascalABC.NET

begin

 var (se, so) := (0, 0);

 foreach var s in ReadLines('input.txt') do

 begin

   var t := s.ToInteger;

   if t.IsEven then

     se += t

   else

     so += t

 end;

 WriteAllText('output.txt', (se / so).ToString)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?