В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yliana23
yliana23
27.02.2023 00:39 •  Информатика

Дописать програму

Составить программу, которая бросать случайные числа из интервала от 10 до 50 пока не выпадет

заданное с клавиатуры число А (10<=A<=50). Указать количество «бросков» до совпадения.

Дописать програму

var

x, count, y:integer;

begin

writeln('Задумайие и введите число X (10<=x<=50)');

readln(x);

y:=

count:=

здесь пропущена строка

begin

y:=random(41)+10;

count:=

writeln('Бросок №',count,': y=',y);

end;

writeln;

writeln('Количество бросков до совпадения ', count)

end

Ответ:
arinabolshakov1
arinabolshakov1
14.10.2020 17:18
ответ:

var

   x, count, y:integer;

begin

   writeln('Задумайие и введите число X (10<=x<=50)');

   readln(x);

   y:=0;

   count:=0;

   while x<>y do

   begin

       y:=random(41)+10;

       count:=count+1;

       writeln('Бросок №',count,': y=',y);

   end;

   writeln;

   writeln('Количество бросков до совпадения ', count)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?