В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LAxPiet
LAxPiet
31.10.2022 16:28 •  Информатика

На вход программе подаётся непустая последовательность целых чисел оканчивающаяся отрицательным числом. Написать программу, которая подсчитает среднее арифметическое этих чисел. Последнее введённое число участвует в получении среднего арифметического. Точность выводимого числа не задаётся.
Входные данные
1 3 4 -1
Выходные данные

Ответ:
kocherovavika2005
kocherovavika2005
14.10.2020 13:00

sr = 0

a = 0

k = 0

while a >= 0:

 a = int(input())

 k += 1

 sr += a

print(sr/k)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?