В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rsdfa
rsdfa
23.02.2022 22:43 •  Информатика

Напишите программу, которая для заданного целого числа определяет:

а) является ли число четным;

б) оканчивается ли оно цифрой 5.

Для решения задачи вспомните операцию mod (остаток от деления) и составьте логические выражения для ответа на во задачи.

Ответ:
tanyalepihina2
tanyalepihina2
13.09.2020 19:58

ответ:Ох уж и не думал что вернусь в этот язык

Объяснение:

program название;

var a;

Begin

Writeln ("Введите число:");

Readln(a);

if (a mod 2 <> 1) then Write("Число нечетно");

else write ("Число чётное");

if (a mod 5 <> 5 and a mod 10 <> 5) then write ("Число не оканчивается на 5")

else Write ("Число оканчивается на 5");

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?