В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TheNekyTyan
TheNekyTyan
28.01.2020 20:03 •  Информатика

Ребят , сколько сможете
Задание 1
Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.
Задание 2
Напишите программу, которая находит минимальное четное среди отрицательных и максимальное нечетное среди положительных чисел, записанных в файле, и выводит результат в виде написанных в столбик чисел в другой файл. Учтите, что таких чисел может вообще не быть.

Ответ:
mariooouvanov
mariooouvanov
13.10.2020 21:08

1

var

mas:array[1..100] of integer;

i,n:integer;

en,out:text;

res:real;

qw,qwe:string;  

begin

 n:=0;

 i:=1;

 write('Введите полный путь к импортируемому файлу: ');readln(qw);

 write('Введите полный путь к экспортируемому файлу: ');readln(qwe);

 assign(en,qw+'.txt'); assign(out,qwe+'.txt');  

 reset(en); rewrite(out);

 while not Eof(en) do    

 begin

 readln(en,mas[i]);      

 n:=n+mas[i];                

 inc(i);        

 end;

   res:=(n/(i-1));  

   write(out,res);  

   close(out);      

   close(en);

 end.

Там во вторую тупо добавляешь:

 max:=-100001;

 min:=100001;

if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];

 if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];  

if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')

 else  

 begin

   writeln(out,min);

   writeln(out,max);  

Тоже такие же задачи решал)) лол). Ты не из 604??)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?