В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
masha32434
masha32434
03.05.2023 11:10 •  Информатика

Напишите программу на языке Pascal: нахождение максимального или минимального элемента в массиве из 10 чисел.

Ответ:
dina249
dina249
13.10.2020 19:31

Вариант, когда массив заполняется случайными числами:

var A: array [1..10] of integer;

var i,max,min: integer;

begin

max:=1;

min:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>A[max]) then max:=i;

 if (A[i]<A[min]) then min:=i;

 end;

writeln();

writeln('Минимальный элемент: ',A[min]);

writeln('максимальный элемент: ',A[max]);

end.

Вариант, когда массив вводится с клавиатуры:

var A: array [1..10] of integer;

var i,max,min: integer;

begin

max:=1;

min:=1;

for i:=1 to 10 do

 begin

 readln(A[i]);

 if (A[i]>A[max]) then max:=i;

 if (A[i]<A[min]) then min:=i;

 end;

writeln();

writeln('Минимальный элемент: ',A[min]);

writeln('максимальный элемент: ',A[max]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?