Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
xfcsfttvd
21.05.2020 22:30 •
Информатика
Составить программу,которая формирует список l, включив в него по одному разу элементы,которые входят одновременно в оба списка l1 и l2. pascal abc.net
Ответ:
antonkovalenko1
03.10.2020 01:32
// PascalABC.NET 3.0, сборка 1088
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
0,0
(0 оценок)
Популярные вопросы: Информатика
kadalsu4
10.03.2020 23:54
Написать программу в паскале.вычислите объём параллелипипеда со сторонами a, b , c...
rous59
23.04.2023 04:03
44. какое из названных действий можно произвести со сжа- тым файлом: а) переформатировать; б) распаковать; в) просмотреть; г) запустить на выполнение....
DariaTheBest5
23.04.2023 04:03
Решить , о школьном кондитерском цехе рассмотренную в новой постановке. пусть цех производит 4 вида продукции: пирожки (максимально возможно произвести 2000 шт. в день, если...
Natalym2001
04.03.2023 23:16
Укажите, какое логическое выражение равносильно выражению ¬(av¬bvc) выбрать ответ: 1) ¬avdv¬c; 2) a λ ¬b λ c 3) ¬av¬bv¬c; 4) ¬a λ b λ ¬c...
Elizabeth1006
04.03.2023 23:16
Расставьте между цифрами знаки арифметических действий и если надо скобки чтоб ответ оказался 1 1 2 3 4 5 =1 1 2 3 4 5 6 =1 1 2 3 4 5 6 7 =1 1 2 3 4 5 6 7 8 =1...
Эзоз
30.08.2022 23:49
Вопрос по информатике и икт! выберите правильные утверждения об информационных моделях: 1. рисунок мяча -это его модель 2. модели изучать мир 3. модели просто для красоты...
dfgds1
30.08.2022 23:49
07.11.2001. записать в римской системе эти числа....
dedovu6
01.05.2022 14:50
Какое количество информации нечет сообщение о том, что встреча состоится 23 октября в 15: 00. расскажи как решать такие ?...
Ariana030709
14.10.2021 01:08
Известно, что 15х = 12у. Найдите отношение х к у....
Витаминка8990
14.10.2021 01:08
При строительстве здания 3 строителя за 8 ч выложили из кирпичей стену высотой 4 м. За какое время смогла бы выложить стену высотой 10 м бригада из 4 человек...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]