В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу, которая будет выводить четырехзначное число в обратном поряядке.

Ответ:
SEITZHANOFF
SEITZHANOFF
13.09.2020 12:24

Объяснение:

program Xxx;

const

  RndLimit = 10000;

var

  x : integer;

begin

Repeat x := Random(RndLimit) until x > 999;

  writeLn('Random X= ', x);

  WriteLn('Modifyed X=', (x mod 1000 mod 100 mod 10), (x mod 1000 mod 100 div 10) , (x mod 1000 div 100) , (x div 1000) );

end.

Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64                                                                          

Copyright (c) 1993-2012 by Florian Klaempfl and others                                                                                

Target OS: Linux for x86-64                                                                                                            

Compiling main.pas                                                                                                                    

Linking a.out                                                                                                                          

10 lines compiled, 0.3 sec                                                                                                            

                                                       

Random X= 5488                                                                                                                        

Modifyed X=8845                                                                                                                        

                                                                                                                                     

                                                                                                                                     

...Program finished with exit code 0                                                                                                  

Press ENTER to exit console

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?