В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nik180208mailru
nik180208mailru
03.12.2020 15:22 •  Информатика

Написать программу, которая считывает две строки, введённых пользователем. После этого программа должна вывести на экран, какая строка длиннее и на сколько символов.(Python)(В коде должно быть ветвление if … elif … else
Вычисление разницы в длине строк должно выполняться в функции, которая принимает две строки и возвращает целое число.)

Ответ:
5v09
5v09
12.10.2020 06:42

def get_string_length_diff(string1, string2):

   return len(string1)-len(string2)

fstring = input()

sstring = input()

strings_diff = get_string_length_diff(fstring, sstring)

print(f'первая строка длиннее на {abs(strings_diff)} символов' if (strings_diff > 0) else f'вторая строка длиннее на {abs(strings_diff)} символов')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?