В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
диана2263
диана2263
06.01.2020 23:54 •  Информатика

Необходимо написать программу, которая проверяет, знаете ли вы таблицу умножения. Программа выводит на экран пример, ответ на который должен ввести пользователь. Программа должна вывести на экран, верно ли ответил пользователь, и показать правильный результат, если пользователь ответил неверно.
Генерируйте пример с генератора случайных чисел (random, randint)
Таблица умножения включает в себя числа от 1 до 9
В программе должно быть ветвление if

Ответ:
мдфв224
мдфв224
27.08.2020 23:57

import random

while True:

       a = random.randint(1, 9)

       b = random.randint(1, 9)

       i = 0

       while True:

               try:

                       print("%dx%d=" % (a, b), end="")

                       i = int(input())

               except ValueError:

                       print("Введите число!")

               else:

                       break

       rightAnswer = a * b

       if i == rightAnswer:

               print("Верно!\n")

       else:

               print("Неверно! Верный ответ: %d\n" % rightAnswer)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?