В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hcunvakjb
hcunvakjb
17.03.2020 11:08 •  Информатика

Составить программу на паскале: ) для десяти чисел введенных с клавиатуры все отрицательные сложить а положительные умножить

Ответ:
ынпщщ357
ынпщщ357
21.07.2020 16:59
Var a,b,c,d:integer;
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
0,0(0 оценок)
Ответ:
вова966
вова966
21.07.2020 16:59
Const
  N = 10;

var
  x, i, minus, plus:integer;

begin
  plus:=-1;
  minus:=0;
  for i:=1 to N do
  begin
    readln(x);
    if x<0 then
      minus:=minus+x;
    if x>0 then
      if plus = -1 then      
        plus:=x
      else
        plus:=plus*x;
  end;
  writeln('Сумма отрицательных чисел: ', minus);
  if plus = -1 then
    writeln('Положительных чисел нет')
  else
   writeln('Произведение положительных чисел:', plus);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?