В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Cesar123213
Cesar123213
08.06.2023 19:17 •  Информатика

2) Напишите программу, которая в последовательности натуральных чисел определяет сумму
всех чисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные
числа, количество введённых чисел неизвестно, последовательность чисел заканчивается
числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел
не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно
число: сумму всех чисел, кратных 3 и оканчивающихся на на языке Пайтон

Ответ:
DashaP2006
DashaP2006
12.10.2020 05:08

number = 1

first_list = []

while number != '0':

   number = str(input())

   first_list.append(number)

   if number == '0':

       first_list.remove(number)

       break

second_list = []

for n in first_list:

   if int(n) % 3 == 0 and n[-1] == '9':

       second_list.append(n)

amount = 0

for i in second_list:

   amount += int(i)

print(amount)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?