В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
POLINAzhavoronkova
POLINAzhavoronkova
21.05.2023 11:45 •  Информатика

Составить программу нахождения суммы всех нечетных отрицательных элементов массива,образованного случайными числами в диапазоне от -30 до 30(на языке паскаль)

Ответ:
Yerkosyaorynbekova
Yerkosyaorynbekova
07.07.2020 13:17
Const N = 5;
Var a:array [1..N] of integer; i,S:integer;
Begin
randomize; S:=0;
for i:=1 to N do begin
a[i]:=random(61)-30;
if (a[i]<0) and (a[i] mod 2 <>0) then S:=S+a[i]; end;
writeln(S);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?