В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kodraemail
kodraemail
08.04.2020 17:03 •  Информатика

надо сегодня

3) Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазона от -30 до 30. Подсчитайте в этом массиве количество положительных и количество отрицательных чисел.

5) Найти сумму положительных и количество отрицательных элементов в одномерном массиве: 0; 15; 12; -9; -8; 58; 45; 36; -85; 58; 36; -45; 2; 3; 25; -9.

Ответ:
rimmarimma84
rimmarimma84
11.09.2020 21:30

var a:array[1..100] of integer;

b,c,d:integer;

begin

c:=0;

d:=0;

for b:=1 to 100 do

begin

a[b]:=random(41)-30;

writeln('a[',b,']= ',a[b]);

if a[b]>0 then c:=c+1;

if a[b]<0 then d:=d+1;

end;

writeln('Количество положительных значений равняется ',c);

writeln('Количество отрицательных значений равняется ',d);

end.

5)

var  

int sum=0;

int kolmin=0;

arr=[0,15,12,–9,–8,58,45,36,–85,58,36,–45,2,3,25,–9];

for(i=0;i<16;i++){  

if(arr[i]>0){ sum+=arr[i];}

if(arr[i]<0){kolmin++;}

}

writeln('сумма + элементов = ',sum);

writeln('количество отрицательных элементов = ',kolmin);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?