В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Амон11111
Амон11111
03.11.2022 10:10 •  Информатика

Напишите программу которая находит среднее арифметическое всех элементов массива двоичная запись которых содержит ровно 4 цифры. Python.
Очень

Ответ:
Sravkur
Sravkur
12.10.2020 00:37

если числа изначально в 10 системе:

array = list(map(int, input().split())); res = 0; res1 = 0 #ввод  и переменные

for i in array:

   if len(bin(i)[2:]) == 4: res += i; res1 += 1  #пробегаемся по массиву и смотрим подходит ли элемент в двоичном представлении

try:

   print(res / res1)  #если не было подходящих будет деление на 0, поэтому я использовал try except

except: print(0)  #ну если все же подходящих не было выводим 0

если уже в 2:

array = list(map(int, input().split())); res = 0; res1 = 0

for i in array:

   if len(str(i)) == 4: res += i; res1 += 1

try:

   print(res / res1)

except: print(0)

Вроде бы как-то так


Напишите программу которая находит среднее арифметическое всех элементов массива двоичная запись кот
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?