В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bestsoule
bestsoule
07.06.2020 01:01 •  Информатика

Написать программу по вычислению 7!, используя цикл с предусловием(1) и использую цикл с параметром (2)

Ответ:
Derve
Derve
11.10.2020 23:36

Объяснение:

Программа на питоне

a=1

for i in range(1,8)

a = a*i

0,0(0 оценок)
Ответ:
Duglas17
Duglas17
11.10.2020 23:36

C предусловием:

var

 i, y: integer;

begin

 y := 1;

 i := 7;

 while i > 1 do

 begin

   y := y * i;

   i := i - 1;

 end;

 writeln('Цикл с предусловием, факториал равен: ', y);

end.

C параметром:

const n=7;

var

i, s: integer;

begin

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln('Цикл с параметром, факториал равен: ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?