В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
аннасерб
аннасерб
01.10.2022 15:45 •  Информатика

Pascal
1. напишите программу, которая в последовательности натуральных чисел определяет сумму чисел,
кратных 5. программа получает на вход количество чисел в последовательности, а затем сами
числа. в последовательности всегда имеется число, кратное 5. количество чисел не превышает
100. введённые числа не превышают 300. программа должна вывести одно число — сумму чисел,
кратных 5.

2. напишите программу, которая в последовательности натуральных чисел определяет минимальное
число, оканчивающееся на 4. программа получает на вход количество чисел в
последовательности, а затем сами числа. в последовательности всегда имеется число,
оканчивающееся на 4. количество чисел не превышает 1000. введённые числа не превышают 30
000. программа должна вывести одно число — минимальное число, оканчивающееся на 4.

Ответ:
yMHNk1
yMHNk1
11.10.2020 02:28

Всё напишу в объяснении.

Объяснение:

1) Program Ex1;

var

 n, a, i, sum : integer;

begin

 sum := 0; // обнуляем счетчик суммирования

 read(n);  // вводим кол-во чисел

 for i := 0 to n do

   begin

   read(a); // считываем эти числа

   if (a mod 5 = 0) then sum := sum + a; // если число кратно 5, то добавляем его к сумме

   end;

 writeln(sum); // выводим сумму.

end.

2) Program Ex2;

var

 n, a, i, min: integer;

begin

 min := 30000;

 read(n);  // вводим кол-во чисел

 for i := 0 to n do

   begin

   read(a); // считываем эти числа

   if ((a mod 10 = 4) and (a < min)) then min := a; // ищем минимум

   end;

 writeln(min); // выводим минимум

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?