В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
EgorT222
EgorT222
26.02.2023 18:08 •  Информатика

Дан массив из 10 целых чисел. написать программу нахождения суммы положительных элементов массива паскаль

Ответ:
dimabeliu2016
dimabeliu2016
05.08.2020 14:36

var  

 mas: array[1..10] of integer;

 i, sum: integer;

begin

 sum:=0;

 for i:=1 to 10 do

   begin

 write(i, ' элемент массива: ');

 readln(mas[i]);

 if mas[i] > 0 then

   sum:=sum+mas[i];

   end;

   writeln('Сумма положительных элементов массива: ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?