В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zeleninalina20
zeleninalina20
27.07.2021 01:20 •  Информатика

Надо написать программу, определяющую сколько слов в тексте начинается на букву "а". (паскаль)

Ответ:
bolotovaanna7
bolotovaanna7
10.10.2020 19:12

uses crt;

var  st,buf:string;

k:integer;

begin

k:=0;

clrscr;

write('-> ');

readln(st);

repeat

 if (st[1]=' ') or (length(st)=0) then while st[1]=' ' do delete(st,1,1)

 else

 begin

  while (st[1]<>' ') and (length(st)>0) do

  begin

   buf:=buf+st[1];

   delete(st,1,1);

  end;

 if upcase(buf[1])='A' then inc(k);

 buf:='';

 end;

until (length(st)=0) and (length(buf)=0);

writeln(k);

readln;

end.

Объяснение:

0,0(0 оценок)
Ответ:
Vadym19
Vadym19
10.10.2020 19:12

Program bykvaa;

Uses crt;

Var  

a:string;

b,i:integer;

begin

writeln('Введите текст:');

readln(a);

if a[1]='а' then b:=b+1;

for i:=2 to length(a) do

begin

 if a[i]='а' then if a[i-1]=' ' then b:=b+1;

end;

writeln('Количество слов в тексте, начинающихся на букву "а": ',b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?