В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kirillchakilev
Kirillchakilev
22.06.2021 01:04 •  Информатика

Составить программу в паскаль по :
найти среднее арифметическое наибольшего и наименьшего элементов в одномерном массиве ​

Ответ:
liza1383
liza1383
10.10.2020 17:38

PascalABC.NET

begin

 var n := ReadInteger('n =');

 var a := ArrRandom(n, -99, 99);

 a.Println;

 Println('Результат:', (a.Max + a.Min) / 2)

end.

Turbo Pascal

program abcd;

uses Crt;

const

 nn = 100;

var

 i, n, max, min: integer;

 a: array[1..nn] of integer;

 

begin

 ClrScr;

 Write('n = ');

 Readln(n);

 Randomize;

 max := -32768;

 min := 32767;

 for i := 1 to n do

 begin

   a[i] := Random(199) - 99;

   Write(a[i], ' ');

   if a[i] > max then

     max := a[i]

   else if a[i] < min then

     min := a[i]

 end;

 Writeln;

 Writeln('Результат: ', (max + min) / 2);

 ReadKey

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?