В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
лиза2291
лиза2291
11.08.2022 11:12 •  Информатика

Напишите программу, которая получает два целых числа (a и b) и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. питон

Ответ:
annashevelina
annashevelina
10.10.2020 13:31

a,b = map(int,input().split())

neg = bool()

zero = bool()

i = int()

ab = int()

if a==0 and b==0:

   zero = True

if not(zero):

   for i in range(abs(a)):

       ab += b

   

if a<0 and not(zero):

   print(ab*-1)

elif zero:

   print(0)

else:

   print(ab)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?