В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ivanmotcrut
Ivanmotcrut
23.04.2021 00:29 •  Информатика

Pascal: написать программу расчета количества рулонов обоев шириной d см, если известны длина, ширина, высота комнаты (a,b,c), размеры одного окна (m,n) и одной двери (p,k). ​дверь одна, окно тоже.

Ответ:
Asherok
Asherok
10.10.2020 13:41

var

 a, b, c, d, l, m, n, p, k, r: integer;

 S, u: real;

begin

 writeln('Оклейка комнаты обоями. Все размеры в см.');

 write('Укажи длину, ширину и высоту комнаты: ');

 readln(a, b, c);

 write('Укажи ширину и высоту двери: ');

 readln(p, k);

 write('Укажи ширину и высоту окна: ');

 readln(m, n);

 write('Укажи длину и ширину рулона обоев: ');

 readln(l, d);

 S := 2 * c * (a + b) - p * k - m * n; { площадь оклейки }

 u := l * d; { площадь одного рулона }

 r := Trunc(S / u);

 if Frac(S / u) > 0.05 then

   r := r + 1;

 writeln('Потребуется рулонов: ', r)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?