В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
пантера49
пантера49
15.06.2020 00:12 •  Информатика

Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2

Ответ:
SIBGATULLINA98
SIBGATULLINA98
10.10.2020 12:55

begin

 Println(1/Sqr(ReadInteger+1))

end.

Примеры:

7

0.015625

-4

0.111111111111111

0

1

-1

Infinity (это означает бесконечность)

0,0(0 оценок)
Ответ:
КРЕНДЕЛЬ228
КРЕНДЕЛЬ228
10.10.2020 12:55

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

y := 1 / sqr(x+1);

if (sqr(x+1) = 0) then

writeln ('Знаменатель = 0')

else

writeln ('Значение y = ', y);

end.

----------------------------------

Или

----------------------------------

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

if (x <> -1) then

Begin

y := 1 / sqr(x+1);

writeln ('Значение y = ', y)

end

else

writeln ('Знаменатель = 0');

end.


Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?