В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mebelru
mebelru
22.10.2021 22:27 •  Информатика

Написать программу на паскале. дана последовательность из n целых положительных чисел и числа x и y, которые встречаются в это последовательности. определить, верно ли , что число x встречается в ней чаще , чем y.

Ответ:
аркадий47
аркадий47
10.10.2020 08:03

var

 x,y,n,i,a:integer;

 countX, countY:integer;

begin

 write('N: ');

 readln(n);

 write('X, Y: ');

 readln(x,y);

 countX:=0; countY:=0;

 for i:=1 to N do

   begin

     readln(a);

     if a=x then inc(countX);

     if a=y then inc(countY);

   end;

 if countX > countY then  

   writeln('Verno')

     else

       writeln('Error');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?