В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
romamuver
romamuver
10.09.2021 05:16 •  Информатика

Составить программу на c++ для вычисления произведения​

Ответ:
Pikaduwert
Pikaduwert
06.08.2020 10:23

#include <iostream>

using namespace std;

int main()

{

   int n; // конечное значение

   int i; // счетчик цикла

   cout << "Введите конечное число: ";

   cin >> n;

   int r = 1;

   setlocale(0, "");

       for (i = 1; i <= n; i=i+2) // задаем начальное значение 1, конечное n и задаем шаг цикла - 2.

   {

       r = r * i;

   }

   cout << "Факториал нечетных чисел от 1 до " << n << " = " << r << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?