В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
czartan
czartan
21.12.2021 16:02 •  Информатика

Даны две дроби a b и c d

напишите программу, которая находит целую часть их суммы.

входные данные в первой строке указаны через пробел целые числа a, b, c и d

(1 6 a, b, c, d 6 100).

результат выведите целую часть суммы a

b + c=d
выразить в программу паскаль

Ответ:
yanameleshko2016
yanameleshko2016
10.10.2020 06:08

Для начала решим это математически:

Пусть \frac{a}{b} и \frac{c}{d} - данные дроби.

Их сумма будет:

\frac{a}{b}+\frac{c}{d}=\frac{a*d+b*c}{b*d}

И нужно найти целую часть от деления (a*d+b*c) на (b*d).

Теперь составляем программу:

var a,b,c,d: integer;

begin

readln(a,b,c,d);

write(abs(a*d+b*c) div abs(b*d));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?