В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу на c++, которая проверяет пользователя на знание таблицы умножения. пользователь сам вводит два целых однозначных числа. программа должна задать вопрос («каков результат умножения первого числа на второе»). пользователь должен ввести ответ и увидеть на экране правильно он ответил
или нет. если нет – ещё и показать верный результат.

Ответ:
лусине2007
лусине2007
10.10.2020 05:24

#include <iostream>

using namespace std;

int main(){

int a,b,z;

cin >> a >> b;

cout << "Каков результат умножения первого числа на второе?"

cin>> z;

if (a*b==z) cout << "Правильно!";

else cout << "Неправильно!\n Правильный ответ: " << a * b;

return 0;

}

0,0(0 оценок)
Ответ:
Приветипока
Приветипока
18.01.2024 09:19
Добрый день! Конечно, я помогу вам написать программу на C++, которая проверяет пользователя на знание таблицы умножения.

Вот пример кода для такой программы:

```cpp
#include
using namespace std;

int main() {
int num1, num2, answer, correctAnswer;

// Пользователь вводит первое число
cout << "Введите первое число (от 1 до 9): ";
cin >> num1;

// Пользователь вводит второе число
cout << "Введите второе число (от 1 до 9): ";
cin >> num2;

// Задаем вопрос пользователю
cout << "Каков результат умножения " << num1 << " на " << num2 << "? ";
cin >> answer;

// Вычисляем правильный ответ
correctAnswer = num1 * num2;

// Проверяем ответ пользователя
if (answer == correctAnswer) {
cout << "Правильный ответ!";
} else {
cout << "Неправильный ответ. Правильный результат: " << correctAnswer;
}

return 0;
}
```

Шаги программы:

1. Пользователю предлагается ввести первое число от 1 до 9.
2. Пользователю предлагается ввести второе число от 1 до 9.
3. Задается вопрос: "Каков результат умножения первого числа на второе?"
4. Пользователь вводит свой ответ.
5. Программа вычисляет правильный ответ, умножив первое число на второе.
6. Проверяется, правильно ли ответил пользователь.
7. Если пользователь ответил правильно, выводится сообщение "Правильный ответ!".
8. Если пользователь ответил неправильно, выводится сообщение "Неправильный ответ. Правильный результат: [верный ответ]".

Надеюсь, этот ответ полностью соответствует вашим ожиданиям! Если у вас возникнут дополнительные вопросы, не стесняйтесь их задавать.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?