В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aidaAim
aidaAim
04.05.2020 07:19 •  Информатика

Напишите программу решения следующей : создать двумерный динамический массив произвольного размера .ввести значения элементов массива.найти значение минимального элемента массива,поменять его местами с первым элементом

Ответ:
sab435
sab435
10.10.2020 05:05

#include <iostream>

#include <time.h>

using namespace std;

int main()

{

srand(time(0));

int a, b;

int min = 100, posI, posJ;

cin >> a >> b;

int** matrix = new int*[a];

for (int i = 0; i < a; i++)

 matrix[i] = new int[b];

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  matrix[i][j] = rand() % min;

}

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  cout << matrix[i][j] << '\t';

 cout << endl;

}

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  if (matrix[i][j] < min)

  {

   posI = i;

   posJ = j;

   min = matrix[i][j];

  }

}

matrix[posI][posJ] = matrix[0][0];

matrix[0][0] = min;

cout << endl;

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  cout << matrix[i][j] << '\t';

 cout << endl;

}

for (int i = 0; i < a; i++)

 delete[] matrix[i];

delete[] matrix;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?