В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
аличка77
аличка77
10.03.2022 20:41 •  Информатика

Напишите программу, которая получает на вход три вещественных числа и находим сумму положительных из них. обьясните каждую строку.

Ответ:
Marinap0385
Marinap0385
10.10.2020 04:34

Ну, наверное это должно выглядеть как то так. Я плохо помню паскаль

program Help;   #Заголовок

var  #Раздел с переменными

a, b ,c, summ : real;   #Входные переменные и по итогу их сумма, вещественные

begin  #Думаю понятно

   summ := 0;   #Инициализация summ, ибо статическая типизация

   writeln('Enter nums');   #Программа попросит ввести числа

   readln(a);  #Считывание

   readln(b);  #Считывание

   readln(c);  #Считывание

   

   if a > 0 then summ += a;  #Если переменная а больше нуля, прибавляем её к итоговой переменной

   if b > 0 then summ += b;  #Аналогично

   if c > 0 then summ += c;   #Аналогично

   

   write(summ);   #Выводим переменную summ на экран

       

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?