В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Эверяшка
Эверяшка
07.10.2020 19:50 •  Информатика

Напишите программу на языке pascal. 1. выведите первые 10 целых положительных чисел, которые делятся на 5 и 7 одновременно. 2. пользователь вводит произвольную последовательность целых чисел, заканчивающуюся вводом "0". найти среднее арифметическое среди нечетных положительных чисел
последовательности. 3. выведите таблицу стоимости товара, продаваемого на развес, начиная со 100 г и заканчивая 1.5 кг. пользователь программы вводит стоимость одного килограмма данного товара.

Ответ:
AnitaGo
AnitaGo
10.10.2020 03:46

1. program ex1;

uses crt;

var i, count : integer;

begin

 count:=0;

 for i:=1 to 9999 do

 begin

   if (i mod 5 = 0) and (i mod 7 = 0) then

   begin

     writeln(i);

     count:=count+1;

     if count=10 then

       break;

   end;      

 end;

end.

2. program ex2;

var sum, count, n : integer;

begin

 count:=0;

 n:=9999;

 sum:=0;

 while not (n = 0) do

 begin

   readln(n);

   if (not n mod 2 = 0) and (n>0) then

   begin

     sum:=sum+n;

     count:=count+1;

   end;

 end;

 writeln('Ср. арифм. = ', sum/count);

end.

3. program ex1;

var price, i: integer;

begin

 write('Введите цену товара за 1 кг. :');

 readln(price);

 for i:=1 to 15 do

   write(i:6, '|');

 writeln();

 for i:=1 to 15 do

   write('');

 writeln();

 for i:=1 to 15 do

   write((price/10*i):6,'|');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?