В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ITyanI
ITyanI
08.05.2021 11:37 •  Информатика

Напишите программу на языке паскаль. требуется выяснить, является ли введенное пользователем число совершенным. совершенным называется такое число, сумма делителей которого равна этому числу, если не учитывать в ней последний делитель-само заданное число. например, число "6" является совершенным
числом, поскольку оно имеет три делителя: 1, 2, 3 и при этом 1+2+3=6, то есть самому числу

Ответ:
заря24
заря24
10.10.2020 03:46

var N,i,k:integer;

BEGIN

readln(N);

k:=0;

for i:=1 to N div 2 do

if (N mod i=0) then

k:=k+i;

if (k=N) then

writeln('Да') else

writeln('Нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?